[Tuto] Montage d'un IRE maison pour injection

Exclusivement réservé aux questions techniques et mécaniques concernant les SV650 & SV1000 N/S.
Nous vous répondrons au mieux de nos connaissances...
Avatar du membre
Brasiligun
Pilote 50 cm3
Pilote 50 cm3
Messages : 32
Enregistré le : mer. 15 juin, 2016 8:56
Moto : MT-09 ST / GSX-R 600 K8
Localisation : Lille - 59

[Tuto] Montage d'un IRE maison pour injection

Message par Brasiligun » ven. 23 juin, 2017 13:30

Salut à tous! Aujourd'hui je vous montre ma solution pour vous faire un IRE pour moins de 10€ !

J'ai essayé de mixer la méthode de RSV21 et celle-ci: http://sonelec-musique.com/electronique ... e_002.html
Donc avec un PIC18F88, mais ça n'a jamais marché (pas moyen d'avoir de tension au bout des résistances)

J'ai pourtant fait ça bien :hehe: Proteus/Ares, puis gravure/perçage avec le matos de mon bahut

Image

Image

Image

Image

Image


Après moult soulages et gaveries extrêmes, j'ai tenté une autre méthode que je connais et maîtrise vachement mieux, j'ai tapé dans l'Arduino

J'ai commencé à faire mes tests sur une UNO normale. Pour faire des essais, pour remplacer "la boite de vitesse" j'ai utilisé un potentiomètre pour simuler des valeurs et faire mes réglages:

Image

Une fois fait, et après des résultats concluants (cette fois!), je suis parti sur un afficheur bleu (comme ma K7 en YKY)

Pour ce faire, sélection des résistances à partir de la datasheet de l'afficheur:

L'arduino tourne en 5V, l'afficheur en 3.3V, chaque segment est une led qui consomme 20mA donc 0.02A
Classique,petit coup de U = R*I, dans notre cas R = U/R

Donc:
U = 5V - 3.3V = 1.7V
I= 0.020A
R= 1.7/0.020 = 85 Ω (Les résistances existantes qui s'en rapprochent plus sont des 82 Ω)

Image

Maintenant que ça marche, autant miniaturisé la chose, on passe de l'arduino UNO à la Nano (c'est EXACTEMENT) les même (avec convertisseur analogique/numériques de 10bits -> 1023 valeurs)

Image

Petite comparaison:
Image

A partir de la, c'est parti, miniaturisation, et surtout, rendre le système indépendant en alimentation par la moto, on utilise donc un LM7805 (passer de 12V au 5V), avec une petite led 4007 pour protéger le tout
Image

Ensuite, comme j'ai une SVS, je ne suis pas fan de mettre l'IRE dans la partie basse du compteur, j'ai donc foutu l'afficheur dans une petite boite, avec un filtre anti-UV bleu (pour qu'il soit bien visible en plein soleil, ça marche top), pour ensuite placer le tout en affichage tête haute:
Image

Image
(Le petit bouton sur la droite permet de passer du 0 au N pour le neutre)

Petit test en vrai sur la SV:
Image

Et la, j'ai eu un problème. Certaines vitesses étaient nickels, d'autres ne restaient pas fixe. J'ai résolu ce problème, en fait c'est juste le LM7805. Il faut "lisser" sa tension en ajoutant des condensateurs: entre (l'entrée) le 12V et la masse [patte 1 et 2] j'ai mis un condo polarisé (attention au sens ou il éclate) de 100uF, et entre (la sortie) le 5V et la masse [patte 2 et 3], un condo de 100nF
Image

Image

ET VOILA! A partir de la, tout marche nickel nickel! J'ai juste du confirmer certaines vitesses, la moto tournantes sur béquille d'atelier (comme une cartographie si vous voulez)

Voila mon rendu final:

Image

J'ai réglé mon arduino pour qu'elle traite 4 fois le signal en 1 seconde, c'est bien assez réactif comme ça, et au moins ça évite qu'elle tourne à fond, et donc qu'elle chauffe pour rien

Vous avez donc la possibilité d'avoir un IRE Maison, de la couleur que vous voulez, avec réglage du neutre, pour un total de moins de 10€ ! No fake, une arduino nano non sous licence d'arduino (un clone identique) , coûte 4,20€ et l'afficheur sur eBay, 3€


Voila une petite vidéo qui résume ce méga pavé (promis, ça fait peur mais c'est facile :hehe:):


Si vous avez la moindre question, n’hésitez pas!


V les mecs! :hello:
Si t'as peur fait comme moi! Fermes les yeux

Image

Gabriel
Pilote 50 cm3
Pilote 50 cm3
Messages : 27
Enregistré le : sam. 04 mars, 2017 18:43

[Tuto] Montage d'un IRE maison pour injection

Message par Gabriel » ven. 23 juin, 2017 23:58

Salut à tous,

J'ai déjà un IRE Gipro universel dont je ne trouve pas comment l'installer sur la SV, je souhaite donc en réaliser un moi même vu que je ne veux pas remettre une seconde fois plus de 100 euro la dedans.

Les photos du premier tuto ne sont plus en ligne et je ne connais rien en électronique, arduino ...
Je me demande si c'est facilement réalisable même pour un novice.

Donc si ils y en a parmi vous qui pourraient m'éclairer sur le sujet, voir même de m'aider a brancher le Gipro que j'ai (il faut que je trouve un fil pour la vitesse et un pour le RPM mais je ne sais pas ou ils sont), merci.

Avatar du membre
nikochook
Pilote Supersport
Pilote Supersport
Messages : 2280
Enregistré le : mar. 17 févr., 2009 23:20
Moto : Ex Sv650S k4

[Tuto] Montage d'un IRE maison pour injection

Message par nikochook » dim. 25 juin, 2017 6:27

Brasiligun a écrit : Salut à tous! Aujourd'hui je vous montre ma solution pour vous faire un IRE pour moins de 10€ !

J'ai essayé de mixer la méthode de RSV21 et celle-ci: http://sonelec-musique.com/electronique ... e_002.html
Donc avec un PIC18F88, mais ça n'a jamais marché (pas moyen d'avoir de tension au bout des résistances)

J'ai pourtant fait ça bien :hehe: Proteus/Ares, puis gravure/perçage avec le matos de mon bahut

Image

Image

Image

Image

Image


Après moult soulages et gaveries extrêmes, j'ai tenté une autre méthode que je connais et maîtrise vachement mieux, j'ai tapé dans l'Arduino

J'ai commencé à faire mes tests sur une UNO normale. Pour faire des essais, pour remplacer "la boite de vitesse" j'ai utilisé un potentiomètre pour simuler des valeurs et faire mes réglages:

Image

Une fois fait, et après des résultats concluants (cette fois!), je suis parti sur un afficheur bleu (comme ma K7 en YKY)

Pour ce faire, sélection des résistances à partir de la datasheet de l'afficheur:

L'arduino tourne en 5V, l'afficheur en 3.3V, chaque segment est une led qui consomme 20mA donc 0.02A
Classique,petit coup de U = R*I, dans notre cas R = U/R

Donc:
U = 5V - 3.3V = 1.7V
I= 0.020A
R= 1.7/0.020 = 85 Ω (Les résistances existantes qui s'en rapprochent plus sont des 82 Ω)

Image

Maintenant que ça marche, autant miniaturisé la chose, on passe de l'arduino UNO à la Nano (c'est EXACTEMENT) les même (avec convertisseur analogique/numériques de 10bits -> 1023 valeurs)

Image

Petite comparaison:
Image

A partir de la, c'est parti, miniaturisation, et surtout, rendre le système indépendant en alimentation par la moto, on utilise donc un LM7805 (passer de 12V au 5V), avec une petite led 4007 pour protéger le tout
Image

Ensuite, comme j'ai une SVS, je ne suis pas fan de mettre l'IRE dans la partie basse du compteur, j'ai donc foutu l'afficheur dans une petite boite, avec un filtre anti-UV bleu (pour qu'il soit bien visible en plein soleil, ça marche top), pour ensuite placer le tout en affichage tête haute:
Image

Image
(Le petit bouton sur la droite permet de passer du 0 au N pour le neutre)

Petit test en vrai sur la SV:
Image

Et la, j'ai eu un problème. Certaines vitesses étaient nickels, d'autres ne restaient pas fixe. J'ai résolu ce problème, en fait c'est juste le LM7805. Il faut "lisser" sa tension en ajoutant des condensateurs: entre (l'entrée) le 12V et la masse [patte 1 et 2] j'ai mis un condo polarisé (attention au sens ou il éclate) de 100uF, et entre (la sortie) le 5V et la masse [patte 2 et 3], un condo de 100nF
Image

Image

ET VOILA! A partir de la, tout marche nickel nickel! J'ai juste du confirmer certaines vitesses, la moto tournantes sur béquille d'atelier (comme une cartographie si vous voulez)

Voila mon rendu final:

Image

J'ai réglé mon arduino pour qu'elle traite 4 fois le signal en 1 seconde, c'est bien assez réactif comme ça, et au moins ça évite qu'elle tourne à fond, et donc qu'elle chauffe pour rien

Vous avez donc la possibilité d'avoir un IRE Maison, de la couleur que vous voulez, avec réglage du neutre, pour un total de moins de 10€ ! No fake, une arduino nano non sous licence d'arduino (un clone identique) , coûte 4,20€ et l'afficheur sur eBay, 3€


Voila une petite vidéo qui résume ce méga pavé (promis, ça fait peur mais c'est facile :hehe:):


Si vous avez la moindre question, n’hésitez pas!


V les mecs! :hello:
Vraiment cool ce que tu as fait! On a tout pour le faire d'un point de vue matériel mais après la partie soft fait savoir programmer non? Tu partages ta programation ?
En tous cas top! :super:

Avatar du membre
Brasiligun
Pilote 50 cm3
Pilote 50 cm3
Messages : 32
Enregistré le : mer. 15 juin, 2016 8:56
Moto : MT-09 ST / GSX-R 600 K8
Localisation : Lille - 59

[Tuto] Montage d'un IRE maison pour injection

Message par Brasiligun » lun. 26 juin, 2017 1:22

Vraiment cool ce que tu as fait! On a tout pour le faire d'un point de vue matériel mais après la partie soft fait savoir programmer non? Tu partages ta programation ?
En tous cas top! :super:
Bien sûr! :frime: Pour le fofo pas de pb, il faudra juste étalonner quelques valeurs toi même en fonction de ta brêle et de ton montage (question de parasites etc), mais tout est prêt

Si tu veux te lancer, hésites pas, et mp moi pour le code

Par contre, juste au cas ou, je ne sais pas si ça passe pour une carbu, je sais pas si la boite renvoie une information
Si t'as peur fait comme moi! Fermes les yeux

Image

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » mer. 26 juil., 2017 20:23

Bonjour à tous,

Je suis en cours de finalisation du projet.
Mais j'ai encore besoin d'acheter un boitier, schatn que j'ai une version S, je pourrais le caler sous la bulle ou au niveau des écopes, je pensais prendre ceci : https://www.gotronic.fr/art-boitier-eco ... 1-6161.htm
Sinon, quelle est en gros la longueur de cable nécessaire entre l'afficheur led positionné sous l'ecran de notre compteur et le calculteur qui sera dans le boitier externe ?

Merci à vous.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » jeu. 27 juil., 2017 0:26

Moi perso je dois avoir ptete 20cm, pas plus, et je dois avoir 1m entre le calculateur et la prise pour récupérer la tension, et encore plus pour la brancher sur le + après contact.
Le miens est fini aussi, j'ai pris une boite du même type, la prochaine étape pour moi c'est le démontage de la tête de fourche et l'installation.

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » jeu. 27 juil., 2017 7:45

Ok merci, pour le + après contact et le moins pourquoi tu ne te repique pas sur l'éclairage ?
Je regardais aussi en boitier étanche et connectique étanche, laisse tomber le prix, je vais rester sur du non étanche et mettre tout ça à l'abri.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » jeu. 27 juil., 2017 11:42

Disons que je voulais faire un truc propre, histoire de pas venir couper un fil etc... Ya une prise au niveau de la batterie faite pour ça donc bon :]
Pour le boîtier étanche, de toute façon va falloir percer pour sortir les fils, alors l'intérêt est plus que limité je trouve.

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » jeu. 27 juil., 2017 12:38

Bon finalement j'ai pris ca https://www.gotronic.fr/art-boitier-tek ... 1-6144.htm
avec un presse étoupe pour l’étanchéité.
J'ai hate de pouvoir monter tout ça, mais pas avant le WE prochain, il me faut du temps et de l'espace, en espérant que tout fonctionne nickel aussi sinon je vais :'(.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » sam. 05 août, 2017 18:49

Salut tout le monde,

Je suis en train de monter l'IRE, enfin essayer, car je ne trouve pas ce putain de cable rose censé emmener l'information à l'IRE maison, il passe par où ? C'EST BON TROUVE ::d

Et d'autre part, comment arriver à démonter le compteur sur le SV1000S. En effet je ne sais pas si je dois tomber tout le plastique noir derrière la tête de fourche ou pas ? en gros démonter la bulle, désolidariser les connexions phares, etc...

Merci d'avance pour vos réponses, sachant que je n'ai que jusqu'à demain midi pour faire le montage. 8/
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » lun. 07 août, 2017 9:51

Bon tout est monté nickel sauf sauf sauf que ca ne marche pas ..... :'( J'ai bien le 12V qui alimente le CI et l'info venant du capteur de vitesse qui arrive bien ! Je ne vois pas ce que je pourrais tester de plus avec mon multimètre. Toute aide est la bienvenue
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » lun. 07 août, 2017 10:33

Salut.
Est-ce que tu as testé sans branché à la moto ? Est-ce que sans récupérer la valeur de la vitesse déjà ça marche ? (Logiquement il est quand même censé s'allumer)
Tu peux détailler un peu plus ce qui ne marche pas ?

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » lun. 07 août, 2017 11:08

Salut,
ok je vais essayer de détailler :
Je suis parti sur ce schèma : http://sonelec-musique.com/electronique ... e_002.html
J'ai testé toutes les connectivité avec le tester de continuité du multimètre.
J'ai voulu tester le +5V que je suis censé obtenir après le régulateur, mais je n'avais que 0,6V max. Déjà la je ne comprenais pas pour pourquoi. Pour tester je me suis mis sur la 3 sorti +5v et après le moins à la masse, mais je ne sais pas si je suis bon déjà à ce niveau là.
Ensuite j'étais au point mort, j'ai pris l'option d'afficher le n donc j'aurais du avoir une tension sur les sorties E G et C. J'obtenais une tension qui varié entre 0,3V et 0,6V sur les sorties A F et G avant le résistor que l'ont met entre la sortie du PIC et l'afficheur.
Pour l'afficheur j'ai pris celui-ci http://www.kingbrightusa.com/images/cat ... 11SRWA.pdf
Et au niveau des résistances, j'ai cru comprendre qu'il fallait que je mette des résistances 1/2W 470 Ω par rapport à cet afficheur mais je ne sais pas non plus si je suis juste.

J'ai tout remonté car sur à 100% des connectivités. J'ai mis la résistance de 6,8K sur le fil rose et j'ai pris l'info du fil rose avant cette résistance.
Donc pour moi voilà où j'ai des doutes : la résistance qui ne convient pas avant l'afficheur, pas assez de jus car je n'obtenais pas les +5v après le régulateur...

Sinon tu me dis tester avant de monter sur la moto, j''aurais pu tester comment ? car je n'ai pas moyen autre que par le CI d'avoir du 5V

Voilà, en gros.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » lun. 07 août, 2017 17:19

Pour faire fonctionner ton CI, tu dois forcément avoir du 5V.
Si ce n'est pas le cas, cherche pas plus loin déjà, c'est que tu as un problème.
Maintenant, tu disais dans ton premier post l'avoir connecté directement sur du 12V, pas sûr qu'il est apprécié :/
Je suis pas hyper familié avec les CI, j'ai utilisé un arduino, j'ai donc une prise USB (d'ou ma question de savoir si tu avais pu le tester en dehors de la moto)

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » lun. 07 août, 2017 17:54

Quand je dis j'ai connecté au +12V de la batterie, j'ai emmené le +12V au Circuit Imprimé sur le connecteur J2 (http://sonelec-musique.com/images2/elec ... se_002.gif) mais derrière il y a un régulateur de tension qui doit sortir du +5V or je n'avais pas ce +5V mais du 0,6V ce composant semble défectueux alors ? Comment bien le tester ?

Merci.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.