[Tuto] Montage d'un IRE maison pour injection

Exclusivement réservé aux questions techniques et mécaniques concernant les SV650 & SV1000 N/S.
Nous vous répondrons au mieux de nos connaissances...
Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » mer. 16 août, 2017 8:23

Bon j'ai finalement trouvé le soucis, j'ai soudé un composant sur la platine sauf que la piste c'est cassé sur un infime parti juste à coté et cela ne se voyait pas. Donc du coup tout fonctionne, sauf le PIC, il faut que je le refasse programmer car les tensions relevées ne correspondent pas à celle de la configuration du PIC. D'ailleurs à ce sujet, sur le SV1000S, j'ai mis le G-Pack donc une résistance de 6,8 Ko, j'ai pris l'info de la tension juste avant la résistance, or entre la 1ere et la 2nd je n'ai pas la même tension si j'ai la moto éteinte ou allumé, vous avez déjà vu le cas ?
Bon du coup on passe les vitesses quand on roule donc j'ai pris les tension de chaque vitesse moteur allumé au ralenti.
Pour info moteur éteint, je n'ai pas pu monter plus haut que la 2 alors qu'il me semble que quand j'avais le 650 cela était possible.
Il me reste aussi à régler le problème du soleil qui m’empêche de lire l'afficheur.

Une fois tout terminé, je posterais des photos, ainsi que le typon et la technique que j'ai utilisé pour réaliser le Circuit imprimé.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
patricewillems
Pilote 50 cm3
Pilote 50 cm3
Messages : 17
Enregistré le : ven. 16 avr., 2010 8:46
Moto : 650 SVN K6

[Tuto] Montage d'un IRE maison pour injection

Message par patricewillems » jeu. 24 août, 2017 19:52

Bonjour.
Ça y est, mon IRE est fonctionnel, non sans mal et petites galères.
Tout d’abord je voudrais remercier ce forum , cette discussion , Arachh & Brazy pour sa publication youtube et ses réponses apportées à mes questions ainsi que https://www.sonelec-musique.com/electro ... e_002.html dans lesquels j’ai puisé les infos pour réussir.
A mon tour d’apporter ma pierre a l’édifice pour les prochains qui souhaiteraient fabriquer un IRE.
Ne penser pas réaliser votre IRE en une après midi, ce serait une pure utopie.
Cet IRE est composé d’un afficheur 7 segments piloté par un arduino alimenté en 5V par un régulateur.
AFFICHEUR 7 Segments :
afficheur led 7 segments 1 chiffre 0,4" differents coloris d affichage à 2,1 €
Pour rassurer ceux qui hésiteraient à démonter le compteur, j’ai trouvé ça facile, et concernant la découpe pour y intégrer l’afficheur, en cas de soucis la pièce de référence 34125-16G00, vaut 6 € chez Suzuki.
Pour cet afficheur à cathode commune, qui fonctionne en 3 Vdc et afin d’avoir une bonne luminosité en plein jour et ne pas être ébloui la nuit par la lumière bleue de l’afficheur, j’ai mis 1 résistance par segment de 330 Ohms.
Enfin, au début de tout ceci, comme je n’étais pas totalement sur de mon coup, j’ai opté pour l’option « démontable ».Le raccordement de l’Arduino a l’afficheur a été réalisé avec de la nappe de disque dur IDE, le connecteur femelle sous le compteur venant de l’afficheur, le male lui venant de l’arduino. Le câble venant de l’arduino est un simple câble réseau informatique, 8 fils, 7 segments et une masse. On trouve tout ceci pour presque rien chez Conrad.
REGULATEUR DE TENSION 5 VDC pour Arduino :
J’ai préféré mettre un régulateur qui accepte une grande plage en tension d’entrée à 3,8 €
Convertisseur CC/CC pour circuits imprimés RECOM R-78E5.0-0.5 Nbr. de sorties: 1 x 24 V/DC 5 V/DC 500 mA 1 pc(s)
J’y ajouté un condensateur polarisé de 4700 µf 16V à sa sortie 5V pour éviter les reboots intempestifs de l’arduino.
Venons-en à la tension venant du sélecteur de vitesse à connecter à une entrée analogique de l’arduino.
Il s’agit d’un fil rose est qui se situe derrière le petit carénage gauche, connecteur 3 broches. Il faut démonter la selle conducteur, il se situe sous l’extrémité droite du réservoir.
Pour ma part, je ne l’ai pas coupé, j’ai déconnecté le connecteur, déclipsé la cosse du fil rose et j’ai glissé un fin fil dans la cosse, puis reclipsage et reconnexion du connecteur.J’ai protéger l’ensemble avec une diode 1N4004 entre ce fil et l’entrée Arduino .
Jusque là tout va bien, c’est facile et l’après midi est déjà bien avancée !!!
Le gros problème rencontré a été la stabilité de la tension venant du « Fil rose ».A l’arrêt tout est stable, mais dès que le moteur tourne, il n’y a plus rien de cohérent. Si je rentre dans les détails, on est partis pour 2 copies doubles…donc en résumé :
J’ai ajouté a l’arduino un module carte SD, et avec l’aide du filston, on a codé un programme qui stock dans un fichier texte sur la carte SD a un intervalle de 200 ms les valeurs de tension. Un tour a moto en passant les vitesse toutes les 20 secondes et on analyse le fichier texte.
Là dessus on s’est vite aperçu que dès que le moteur tourne, il n’y a plus rien d’exploitable. On a donc parcouru Mult Forum, questions/réponses , merci le NET.
La solution :
Mettre une résistance de 1000 Ohms entre la masse de l’Arduino et l’entrée analogique de L’arduino, ça a pour effet de stabiliser la tension, mais ça plombe de 50 % la précision de mesure, Au lieu de travailler sur une plage de 0 à 5 Vdc on se retrouve a travailler avec une plage de 0 à 2 Vdc.
Une parade, c’est de spécifier à l’Arduino qu’il travaille en 0 à 3,3V au lieu de 0 à 5Vet ça tombe bien, l’Arduino intègre cela grâce à sa sortie 3,3 Vdc.
Je tiens a dispo pour ceux qui veulent se lancer, le programme Arduino avec les indications de branchement.
Dans les cas ou mes seuils de tension différent des vôtres, il vous suffira d’acheter le module SD à 2,95€ (5175# Module carte mémoire micro SD . Arduino, DIY, Raspberry Pi) puis d’aller faire un petit tour de moto, on maintien 20 sec chaque vitesse a la montée ainsi qu’à la descente.
Une analyse des fichiers de la carte SD vous donnera les seuils de tension de votre moto, restera plus qu’a modifier les valeurs dans le programme. Pas de réticence, c’est enfantin et bien expliqué sur le Net.
En espérant avoir été clair, bonne continuation à vous
Patrice

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » ven. 25 août, 2017 12:47

Bonjour à tous,

IRE + G-Pack monté et opérationnel.
Je ne vais pas tous détailler car les posts précédents le font déjà, j'ajoute juste mon expérience personnelle.

J'ai utilisé le projet suivant : http://sonelec-musique.com/electronique ... e_002.html

Afin de réaliser le Circuit imprimé vous pouvez commander ici https://www.util-pocket.com/electroniqu ... mprime.htm
ou bien utiliser cette méthode http://makerspace56.org/realiser-des-ci ... ou-presque
Fichier express PCB https://www.catupload.com/download/5324 ... 03cff.html
Pour l'impression, imprimer normalement avec l'option Top copper layer (pas besoin de mode miroir car on soude les composant de l'autre côté du PCB), et vérifier la taille du circuit imprimé.
C'est celle que j'ai utilisé, il faut par contre être persévérant et s'acharner.
Petits conseil sur cette méthode :
- Bien insister avec le fer à repasser appuyer fort jusqu'à 5 minutes, puis affiner avec la pointe du fer à repasser.
- Repasser toutes les pistes avec un marqueur indélébile.
- Utiliser une solution d'acide chlorhydrique avec de l'eau oxygéné, mettre l'acide puis ajouter de l'eau oxygéné jusqu’à ce que la réaction commence puis en rajouter petit à petit.
- Pour le perçage avec une colonne c'est mieux, mais le foret de 0,8mm étant très fin ne laisser que 0,5cm de forêt après le mandrin et s'armer de patience car plus de 100 trous à réaliser et laisser refroidir le foret aussi.

Image

Une fois le CI réalisé, souder tous les composants (voir le site sonelec-musique, merci à Rémy pour ses conseils et sa disponibilité, ayant récupéré mon vieux programmateur de PIC, je peux vous le programmer si vous le souhaitez), sachant que j'ai découpé la partie afficheur pour la mettre dans le compteur relié au boitier contenant le CI principal via un câble réseau.
Afin de pouvoir démonter le CI principal et que celui-ci soit étanche, j'ai utilisé des petits connecteurs d'alim de ventilateurs d'ordi d'anciennes générations et une nappe style IDE, tous les fils arrivent dans le boitier via un seul trou et un presse étoupe.
Le circuit est protégé en amont par un fusible de 2A.

Image

Image

Image

Image

Moi j'ai coupé le fil rose et mis ma résistance de 6,8ko en amont (bon pour le G-Pack j'ai pas ressenti une grosse amélioration peut-être du fait qu'elle est encore en 106CV par contre j'ai l'impression que je n'ai pu le trou où elle allait s’étouffer en rétrogradage de 4 en 3, ou de 3 en 2 ).
Il me reste juste la visibilité de l'afficheur quand le soleil tape directement dessus qui est limite, je vais mettre un filtre rouge ou alors un film teinté peut être à tester (malgré un afficheur haute luminosité, après j'ai mis des résistances de 470o car j'ai vu que c'est ce qui était recommandé pour celui-ci).
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » dim. 27 août, 2017 20:36

Bon bah vous m'avez motivé à installer le miens aussi, alors c'est chose faite !

Image

Même problème, à haute luminosité, on y voit pas forcément grand chose.
Si jamais l'un de vous trouve une solution qui marche, n'hésitez pas :)

Avatar du membre
patricewillems
Pilote 50 cm3
Pilote 50 cm3
Messages : 17
Enregistré le : ven. 16 avr., 2010 8:46
Moto : 650 SVN K6

[Tuto] Montage d'un IRE maison pour injection

Message par patricewillems » dim. 27 août, 2017 20:52

Slt
Quel principe ?
Arduino ?
Quelle référence d'afficheur ?
Quelle valeur de résistance pour alimenter l'afficheur ?
Beaucoup de question, mais je ne veux pas répondre à la légère.
@+

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » dim. 27 août, 2017 22:50

Bonjour,
Un Arduino Nano
Un afficheur 7 segment anode commune couleur blanche
Résistances 1000 Ohms (Ptete ça le problème)
De toute manière, maintenant c'est installé, donc Je vois pas trop ce que je pourrais faire malheureusement :/

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » sam. 02 sept., 2017 18:22

SAlut,

Pour l'afficheur, j'ai mis des 470ohm en résistance, mais je pense les remplacer par des 200 pour voir la différence.
Par contre moi je me retrouve avec des problèmes de tensions qui ne vont pas, sur une même vitesse elle n'est pas régulière bon ca ok mais elle peut faire passer un palier et aller dans la tranche supérieure pour affiche la 2 alors que je suis encore en 1.
En gros pour le SVS1000S avec le G-Pack (résitance de 6,8kohm), j'ai les tenions suivantes à 1500 / 2000 tr/min :
n : 4,70
1 : 0,30
2 : 0,45
3 : 0,83
4 : 1,38
5 : 2,45
6 : 3,31

Les premières vitesses sont vraiment proches niveau tension, c'est peut-être le problème du 1000 avec le GPack ?
Vous avez des changements d'affichages de temps en temps en restant sur une meme vitesse au selecteur ?

Bien à vous.
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » dim. 03 sept., 2017 14:10

J'ai une 650, du coup j'aurais pas les mêmes valeur que toi :
Neutre: ~5V
1 ère : ~ 1.4V
2 ème: ~ 1.8V
3 ème: ~ 2.5V
4 ème: ~ 3.25V
5 ème: ~ 4.1V
6 ème: ~ 4.55V

Parcontre, j'ai le même problème, de temps en temps, la vitesse affichée saute juste avant de passer une vitesse, je pense juste que c'est mes limites définies qui sont trop juste, mais on va dire que dans 98% des cas, tout est bon.

Avatar du membre
Delirium6
Pilote 125 cm3
Pilote 125 cm3
Messages : 252
Enregistré le : mar. 22 mai, 2007 12:15
Moto : SV1000S K3
Localisation : Anglet-64

[Tuto] Montage d'un IRE maison pour injection

Message par Delirium6 » dim. 03 sept., 2017 16:21

Ok, et tu as mis le g-pack ? tu as mis quelle valeur de résistance ?
Et pour l'eblouissement en plein soleil, je pensais à ceci https://www.ledperf.com/filtres-et-diff ... 30_75.html
soit de la couleur de l'afficheur soit un polarisant, tu en penses-quoi ?
There are 10 types of people in this world. Those who understand "bi-twin" and those who don't.

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » lun. 04 sept., 2017 0:27

Salut,
Non, moi j'ai fabriqué le mien :)
Le mien est blanc, alors bon, pour moi ça marchera pas, mais aucune idée de sa performance pour le soleil :/

jba632
Pilote 50 cm3
Pilote 50 cm3
Messages : 6
Enregistré le : dim. 26 mars, 2017 0:08

[Tuto] Montage d'un IRE maison pour injection

Message par jba632 » lun. 06 nov., 2017 0:27

:) Salut,
Je cherche moi aussi à faire mon IRE mais sur une barbu S... Je partirai plutôt sur la première méthode avec les diodes.
J'ai trouvé un capteur avec tout les plots soudé mais il n'y a pas le central (masse). Est-ce que quelqu'un sait si je peux récupérer cette masse n'importe où?
Celle-ci n'est pas utile pour l'IRE mais elle est connecté sur le faisceau d'origine avec le neutre...
Merci d'avance

Avatar du membre
4m0ni4c
Pilote 50 cm3
Pilote 50 cm3
Messages : 195
Enregistré le : dim. 23 avr., 2017 22:29
Moto : SVS 650 K8
Localisation : Paris

[Tuto] Montage d'un IRE maison pour injection

Message par 4m0ni4c » sam. 11 nov., 2017 11:30

Salut,
Oui aucun problème, quand je faisais mes test je m'étais piqué sur la masse des clignotants et ça marchait sans problème.
La maintenant il est branché sur la masse près du fil rose de récupération de la tension et ca marche aussi.

jba632
Pilote 50 cm3
Pilote 50 cm3
Messages : 6
Enregistré le : dim. 26 mars, 2017 0:08

[Tuto] Montage d'un IRE maison pour injection

Message par jba632 » sam. 11 nov., 2017 17:39

Salut, merci pour la confirmation. Petite question en passant, vous prenez quel puissance pour vos résistances ? 0,25w c'est un peu léger non? Plutôt 0,5w?
Merci

Avatar du membre
patricewillems
Pilote 50 cm3
Pilote 50 cm3
Messages : 17
Enregistré le : ven. 16 avr., 2010 8:46
Moto : 650 SVN K6

[Tuto] Montage d'un IRE maison pour injection

Message par patricewillems » sam. 11 nov., 2017 18:24

Slt

Dans mon montage j'ai pris du 0,25.
Pour la prise de masse comme pour le +, pour éviter les mauvais contacts ou mauvaise masse, je me suis repris à la batterie .
Le tout protégé par un fusible.
Bon courage

Avatar du membre
Brasiligun
Pilote 50 cm3
Pilote 50 cm3
Messages : 32
Enregistré le : mer. 15 juin, 2016 8:56
Moto : MT-09 ST / GSX-R 600 K8
Localisation : Lille - 59

[Tuto] Montage d'un IRE maison pour injection

Message par Brasiligun » lun. 02 juil., 2018 15:24

Félicitations Délirium! Nouvelle méthode et par toi même en plus!

Je n'ai plus la SV (vendue), et je viens de voir que la vidéo + les photos du tuto sur le forum sont parties. Je reposterai l’ensemble pour qui veut quand j'aurai le temps
Si t'as peur fait comme moi! Fermes les yeux

Image